<!DOCTYPE html>
<html id="XF" lang="en-US" dir="LTR" data-app="public" data-template="thread_view" data-container-key="node-13" data-content-key="thread-707782" data-logged-in="false" data-cookie-prefix="xf_" data-csrf="1618602670,6bab50f451415098cdd4b813936b5b54" data-style-id="14" class="has-no-js template-thread_view">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
<meta name="viewport" content="width=device-width, initial-scale=1, viewport-fit=cover">
<title>Pakistan Army  Welfare Infrastructure Projects | Pakistan Defence</title>
<meta name="description" content="Beautiful pictures of Army Public School Parachinar. Completed in year 2018." />
<meta property="og:description" content="Beautiful pictures of Army Public School Parachinar. Completed in year 2018." />
<meta property="twitter:description" content="Beautiful pictures of Army Public School Parachinar. Completed in year 2018." />
<meta property="og:url" content="https://defence.pk/pdf/threads/pakistan-army-welfare-infrastructure-projects.707782/" />
<link rel="canonical" href="https://defence.pk/pdf/threads/pakistan-army-welfare-infrastructure-projects.707782/" />
<meta property="og:image" content="https://defence.pk/pdf/attachments/1618595136126-png.734697/" />
<meta property="twitter:image" content="https://defence.pk/pdf/attachments/1618595136126-png.734697/" />
<meta property="twitter:card" content="summary_large_image" />
<meta property="og:site_name" content="Pakistan Defence" />
<meta property="og:type" content="website" />
<meta property="og:title" content="Pakistan Army  Welfare Infrastructure Projects" />
<meta property="twitter:title" content="Pakistan Army  Welfare Infrastructure Projects" />
<meta name="theme-color" content="#294142" />
<style>a:hover{ color: var(--pdf-color, #2e7d32); }</style>
<link href="https://fonts.googleapis.com/css2?family=Open+Sans:wght@300;400;600;700&display=swap" rel="stylesheet">
<link rel="preload" href="/pdf/styles/fonts/fa/fa-regular-400.woff2?_v=5.12.1" as="font" type="font/woff2" crossorigin="anonymous" />
<link rel="preload" href="/pdf/styles/fonts/fa/fa-solid-900.woff2?_v=5.12.1" as="font" type="font/woff2" crossorigin="anonymous" />
<link rel="preload" href="/pdf/styles/fonts/fa/fa-brands-400.woff2?_v=5.12.1" as="font" type="font/woff2" crossorigin="anonymous" />
<link rel="stylesheet" href="/pdf/css.php?css=public%3Anormalize.css%2Cpublic%3Acore.less%2Cpublic%3Aapp.less&amp;s=14&amp;l=1&amp;d=1608041697&amp;k=eaa0f4d98b02ad15c6723198622cc5baee9ff455" />
<link rel="stylesheet" href="/pdf/css.php?css=public%3Alightbox.less%2Cpublic%3Amessage.less%2Cpublic%3Ashare_controls.less%2Cpublic%3Asimilar_threads.less%2Cpublic%3Asiropu_ads_manager_ad.less%2Cpublic%3Asnog_flags.less%2Cpublic%3Astructured_list.less%2Cpublic%3Asv_contentratings.less%2Cpublic%3Athfilters_node_label.less%2Cpublic%3Axc_user_activity.less%2Cpublic%3Aextra.less&amp;s=14&amp;l=1&amp;d=1608041697&amp;k=8c01d0cb08bf485b9f4b2e9735165927833eea20" />
<script src="/pdf/js/xf/preamble.min.js?_v=fe23bc1f"></script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-65577701-1"></script>
<script>
		window.dataLayer = window.dataLayer || [];
		function gtag(){dataLayer.push(arguments);}
		gtag('js', new Date());
		gtag('config', 'UA-65577701-1', {
			// 
			
			
		});
	</script>
<script type='text/javascript'>
var xfhtml = document.getElementById('XF');
function applySetting(settingName, settingOn, allowToggle){
	
	// Theme editor is enabled. Check for selected toggle, otherwise apply default
		if(allowToggle === 1){
			var choice = localStorage.getItem(settingName);
			if( (choice === 'on') || (!choice && (settingOn === 1)) ){
				xfhtml.classList.add(settingName);
			}
		} else if(settingOn === 1){
			xfhtml.classList.add(settingName);
		}
	
}

applySetting('focus-mobile-navigation-bar', 1, 1);


applySetting('focus-fluid', 0, 1);


applySetting('focus-grid', 1, 1);


applySetting('focus-sidebar-sticky', 1, 1);


applySetting('focus-sidebar-flip', 0, 1);





	// xfhtml.setAttribute('data-focus-bg', '1');

</script>
<script>
		var randomBackgrounds = [
			1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27
		];
		var randomBackground = randomBackgrounds[Math.floor(Math.random()*randomBackgrounds.length)];
		xfhtml.setAttribute('data-pdf-random', randomBackground);
	</script>
</head>
<body data-template="thread_view">
<div class="p-pageWrapper" id="top">
<div class='top-bar'>
<div class='top-bar__align focus-width'>
<div id='pdf_date'></div>
<script>
				var months = ["January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November", "December"];
				var days = ['Sunday', 'Monday', 'Tuesday', 'Wednesday', 'Thursday', 'Friday', 'Saturday'];
				
				var n = new Date();
				var y = n.getFullYear();
				var m = n.getMonth();
				var d = n.getDate();
				var day = n.getDay();
				
				document.getElementById("pdf_date").innerHTML = days[day] + ", " + months[m] + " " + d + ", " + y;
			</script>
<div class='focus-wrap-user'>
<div class="p-nav-opposite">
<div class="p-navgroup p-account p-navgroup--guest">
<a href="/pdf/login/" class="p-navgroup-link p-navgroup-link--textual p-navgroup-link--logIn" rel="nofollow" data-xf-click="overlay" data-follow-redirects="on">
<span class="p-navgroup-linkText">Log in</span>
</a>
<a href="/pdf/register/" class="p-navgroup-link p-navgroup-link--textual p-navgroup-link--register" rel="nofollow" data-xf-click="overlay" data-follow-redirects="on">
<span class="p-navgroup-linkText">Register</span>
</a>
<a href="#" class="p-navgroup-link" rel="nofollow" data-xf-init="tooltip" title="Customize" data-xenfocus-editor>
<i class="fa--xf far fa-toggle-on" aria-hidden="true"></i>
</a>
</div>
<div class="p-navgroup p-discovery">
<a href="/pdf/whats-new/" class="p-navgroup-link p-navgroup-link--iconic p-navgroup-link--whatsnew" aria-label="What&#039;s new" title="What&#039;s new">
<i aria-hidden="true"></i>
<span class="p-navgroup-linkText">What's new</span>
</a>
<a href="/pdf/search/" class="p-navgroup-link p-navgroup-link--iconic p-navgroup-link--search" data-xf-click="menu" data-xf-key="/" aria-label="Search" aria-expanded="false" aria-haspopup="true" title="Search" data-xf-init="tooltip">
<i aria-hidden="true"></i>

</a>
<div class="menu menu--structural menu--wide" data-menu="menu" aria-hidden="true">
<form action="/pdf/search/search" method="post" class="menu-content" data-xf-init="quick-search">
<h3 class="menu-header">Search</h3>
<div class="menu-row">
<div class="inputGroup inputGroup--joined">
<input type="text" class="input" name="keywords" placeholder="Search…" aria-label="Search" data-menu-autofocus="true" />
<select name="constraints" class="js-quickSearch-constraint input" aria-label="Search within">
<option value="">Everywhere</option>
<option value="{&quot;search_type&quot;:&quot;post&quot;}">Threads</option>
<option value="{&quot;search_type&quot;:&quot;post&quot;,&quot;c&quot;:{&quot;nodes&quot;:[13],&quot;child_nodes&quot;:1}}">This forum</option>
<option value="{&quot;search_type&quot;:&quot;post&quot;,&quot;c&quot;:{&quot;thread&quot;:707782}}">This thread</option>
</select>
</div>
</div>
<div class="menu-row">
<label class="iconic"><input type="checkbox" name="c[title_only]" value="1" /><i aria-hidden="true"></i><span class="iconic-label">Search titles only</span></label>
</div>
<div class="menu-row">
<div class="inputGroup">
<span class="inputGroup-text" id="ctrl_search_menu_by_member">By:</span>
<input type="text" class="input" name="c[users]" data-xf-init="auto-complete" placeholder="Member" aria-labelledby="ctrl_search_menu_by_member" />
</div>
</div>
<div class="menu-footer">
<span class="menu-footer-controls">
<button type="submit" class="button--primary button button--icon button--icon--search"><span class="button-text">Search</span></button>
<a href="/pdf/search/" class="button" rel="nofollow"><span class="button-text">Advanced search…</span></a>
</span>
</div>
<input type="hidden" name="_xfToken" value="1618602670,6bab50f451415098cdd4b813936b5b54" />
</form>
</div>
</div>
</div>
</div>
</div>
</div>
<div class='focus-wrapper focus-width'>

<header class="p-header" id="header">
<div class="p-header-inner">
<div class="p-header-content">

<div class="p-header-logo p-header-logo--image">
<a href="https://defence.pk" class='focus-logo'>
<span class='focus-logo--image'>
<img src="/pdf/styles/xenfocus/pakistan-defence/logo.png" alt="Pakistan Defence" />
</span>
</a>
</div>

<nav class='focus-wrap-nav'>
<div class="p-nav-scroller hScroller" data-xf-init="h-scroller" data-auto-scroll=".p-navEl.is-selected">
<div class="hScroller-scroll">
<ul class="p-nav-list js-offCanvasNavSource">
<li>
<div class="p-navEl ">
<a href="https://defence.pk" class="p-navEl-link " data-xf-key="1" data-nav-id="home">Home</a>
</div>
</li>
<li>
<div class="p-navEl is-selected" data-has-children="true">
<a href="/pdf/" class="p-navEl-link p-navEl-link--splitMenu " data-nav-id="forums">Forums</a>
<a data-xf-key="2" data-xf-click="menu" data-menu-pos-ref="< .p-navEl" class="p-navEl-splitTrigger" role="button" tabindex="0" aria-label="Toggle expanded" aria-expanded="false" aria-haspopup="true"></a>
<div class="menu menu--structural" data-menu="menu" aria-hidden="true">
<div class="menu-content">
<a href="/pdf/whats-new/posts/" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " data-nav-id="newPosts">New posts</a>
<a href="/pdf/threads/latest" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " data-nav-id="thfilters_all_threads">All threads</a>
<a href="/pdf/threads/latest" class="menu-linkRow u-indentDepth1 js-offCanvasCopy " data-nav-id="thfilters_latest_threads">Latest threads</a>
<a href="/pdf/threads/newest" class="menu-linkRow u-indentDepth1 js-offCanvasCopy " data-nav-id="thfilters_newest_threads">New threads</a>
<hr class="menu-separator" />
<a href="/pdf/search/?type=post" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " data-nav-id="searchForums">Search forums</a>
</div>
</div>
</div>
</li>
<li>
<div class="p-navEl " data-has-children="true">
<a href="/pdf/whats-new/" class="p-navEl-link p-navEl-link--splitMenu " data-nav-id="whatsNew">What's new</a>
<a data-xf-key="3" data-xf-click="menu" data-menu-pos-ref="< .p-navEl" class="p-navEl-splitTrigger" role="button" tabindex="0" aria-label="Toggle expanded" aria-expanded="false" aria-haspopup="true"></a>
<div class="menu menu--structural" data-menu="menu" aria-hidden="true">
<div class="menu-content">
<a href="/pdf/whats-new/posts/" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " rel="nofollow" data-nav-id="whatsNewPosts">New posts</a>
<a href="/pdf/whats-new/media/" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " rel="nofollow" data-nav-id="xfmgWhatsNewNewMedia">New media</a>
<a href="/pdf/whats-new/media-comments/" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " rel="nofollow" data-nav-id="xfmgWhatsNewMediaComments">New media comments</a>
<a href="/pdf/whats-new/profile-posts/" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " rel="nofollow" data-nav-id="whatsNewProfilePosts">New profile posts</a>
<a href="/pdf/whats-new/latest-activity" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " rel="nofollow" data-nav-id="latestActivity">Latest activity</a>
</div>
</div>
</div>
</li>
<li>
<div class="p-navEl " data-has-children="true">
<a href="/pdf/media/" class="p-navEl-link p-navEl-link--splitMenu " data-nav-id="xfmg">Media</a>
<a data-xf-key="4" data-xf-click="menu" data-menu-pos-ref="< .p-navEl" class="p-navEl-splitTrigger" role="button" tabindex="0" aria-label="Toggle expanded" aria-expanded="false" aria-haspopup="true"></a>
<div class="menu menu--structural" data-menu="menu" aria-hidden="true">
<div class="menu-content">
<a href="/pdf/whats-new/media/" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " rel="nofollow" data-nav-id="xfmgNewMedia">New media</a>
<a href="/pdf/whats-new/media-comments/" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " rel="nofollow" data-nav-id="xfmgNewComments">New comments</a>
<a href="/pdf/search/?type=xfmg_media" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " data-nav-id="xfmgSearchMedia">Search media</a>
</div>
</div>
</div>
</li>
<li>
<div class="p-navEl " data-has-children="true">
<a href="/pdf/members/" class="p-navEl-link p-navEl-link--splitMenu " data-nav-id="members">Members</a>
<a data-xf-key="5" data-xf-click="menu" data-menu-pos-ref="< .p-navEl" class="p-navEl-splitTrigger" role="button" tabindex="0" aria-label="Toggle expanded" aria-expanded="false" aria-haspopup="true"></a>
<div class="menu menu--structural" data-menu="menu" aria-hidden="true">
<div class="menu-content">
<a href="/pdf/online/" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " data-nav-id="currentVisitors">Current visitors</a>
<a href="/pdf/whats-new/profile-posts/" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " rel="nofollow" data-nav-id="newProfilePosts">New profile posts</a>
<a href="/pdf/search/?type=profile_post" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " data-nav-id="searchProfilePosts">Search profile posts</a>
</div>
</div>
</div>
</li>
<li>
<div class="p-navEl ">
<a href="https://defence.pk/pdf/rules/" class="p-navEl-link " data-xf-key="6" data-nav-id="forrules">Forum Rules</a>
</div>
</li>
</ul>
</div>
</div>
</nav>

<div class='focus-wrap-search'>
<form action="/pdf/search/search" method="post">

<div class='focus-search'>
<div class='focus-search-flex'>
<input name="keywords" placeholder="Search…" aria-label="Search" data-menu-autofocus="true" type="text" />
<div class='focus-search-prefix'><i class="fa--xf far fa-search" aria-hidden="true"></i></div>
</div>
</div>
<div class="focus-search-menu">
<div class="menu-row">
<select name="constraints" class="js-quickSearch-constraint input" aria-label="Search within">
<option value="">Everywhere</option>
<option value="{&quot;search_type&quot;:&quot;post&quot;}">Threads</option>
<option value="{&quot;search_type&quot;:&quot;post&quot;,&quot;c&quot;:{&quot;nodes&quot;:[13],&quot;child_nodes&quot;:1}}">This forum</option>
<option value="{&quot;search_type&quot;:&quot;post&quot;,&quot;c&quot;:{&quot;thread&quot;:707782}}">This thread</option>
</select>
</div>
<div class="menu-row">
<label class="iconic"><input type="checkbox" name="c[title_only]" value="1" /><i aria-hidden="true"></i><span class="iconic-label">Search titles only</span></label>
</div>
<div class="menu-row">
<div class="inputGroup">
<span class="inputGroup-text">By:</span>
<input type="text" class="input" name="c[users]" data-xf-init="auto-complete" placeholder="Member" aria-labelledby="ctrl_search_menu_by_member" />
</div>
</div>
<div class="menu-footer">
<span class="menu-footer-controls">
<button type="submit" class="button--primary button button--icon button--icon--search"><span class="button-text">Search</span></button>
<a href="/pdf/search/" class="button" rel="nofollow"><span class="button-text">Advanced search…</span></a>
</span>
</div>
</div>
<input type="hidden" name="_xfToken" value="1618602670,6bab50f451415098cdd4b813936b5b54" />
</form>
</div>

<div class="p-nav">
<div class="p-nav-inner">
<div class='focus-mobile-navigation'>
<a class="p-nav-menuTrigger" data-xf-click="off-canvas" data-menu=".js-headerOffCanvasMenu" role="button" tabindex="0">
<i aria-hidden="true"></i>
<span class="p-nav-menuText">Menu</span>
</a>
<div class='focus-mobile-logo'>
<a href="https://defence.pk">
<img src="/pdf/styles/xenfocus/pakistan-defence/logo.png" alt="Pakistan Defence" />
</a>
</div>
</div>
</div>
</div>
</div>
</div>
</header>

<div class='focus-content'>


<div class="p-sectionLinks">
<div class="p-sectionLinks-inner hScroller" data-xf-init="h-scroller">
<div class="hScroller-scroll">
<ul class="p-sectionLinks-list">
<li>
<div class="p-navEl ">
<a href="/pdf/whats-new/posts/" class="p-navEl-link " data-xf-key="alt+1" data-nav-id="newPosts">New posts</a>
</div>
</li>
<li>
<div class="p-navEl " data-has-children="true">
<a href="/pdf/threads/latest" class="p-navEl-link p-navEl-link--splitMenu " data-nav-id="thfilters_all_threads">All threads</a>
<a data-xf-key="alt+2" data-xf-click="menu" data-menu-pos-ref="< .p-navEl" class="p-navEl-splitTrigger" role="button" tabindex="0" aria-label="Toggle expanded" aria-expanded="false" aria-haspopup="true"></a>
<div class="menu menu--structural" data-menu="menu" aria-hidden="true">
<div class="menu-content">
<a href="/pdf/threads/latest" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " data-nav-id="thfilters_latest_threads">Latest threads</a>
<a href="/pdf/threads/newest" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " data-nav-id="thfilters_newest_threads">New threads</a>
</div>
</div>
</div>
</li>
<li>
<div class="p-navEl ">
<a href="/pdf/search/?type=post" class="p-navEl-link " data-xf-key="alt+3" data-nav-id="searchForums">Search forums</a>
</div>
</li>
</ul>
</div>
</div>
</div>
<div class="p-body">
<div class="p-body-inner">


<div class="samCodeUnit" data-position="container_breadcrumb_top_above"><div class="samItem"><center><div id='defence.pk_desktop_banner'></div></center></div></div>
<div class='focus-breadcrumb'>
<div class="p-breadcrumbs-wrap ">
<ul class="p-breadcrumbs " itemscope itemtype="https://schema.org/BreadcrumbList">
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="https://defence.pk" itemprop="item">
<span itemprop="name">Home</span>
</a>
<meta itemprop="position" content="1" />
</li>
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="/pdf/" itemprop="item">
<span itemprop="name">Forums</span>
</a>
<meta itemprop="position" content="2" />
</li>
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="/pdf/#pakistan-defence-military-forums.3" itemprop="item">
<span itemprop="name">Pakistan Defence &amp; Military Forums</span>
</a>
<meta itemprop="position" content="3" />
</li>
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="/pdf/forums/pakistan-army.13/" itemprop="item">
<span itemprop="name">Pakistan Army</span>
</a>
<meta itemprop="position" content="4" />
</li>
</ul>
</div>
<ul class='xenfocus-social'>
<li><a href='https://www.facebook.com/pakistanidefence/' target='_blank'></a></li>
<li><a href='https://www.instagram.com/defencepk/' target='_blank'></a></li>
<li><a href='https://twitter.com/defence_pk' target='_blank'></a></li>
<li><a href='https://play.google.com/store/apps/details?id=com.tapatalk.defencepkforums&hl=en_US' target='_blank'></a></li>
</ul>
</div>
<noscript><div class="blockMessage blockMessage--important blockMessage--iconic u-noJsOnly">JavaScript is disabled. For a better experience, please enable JavaScript in your browser before proceeding.</div></noscript>
<!--[if lt IE 9]><div class="blockMessage blockMessage&#45;&#45;important blockMessage&#45;&#45;iconic">You are using an out of date browser. It  may not display this or other websites correctly.<br />You should upgrade or use an <a href="https://www.google.com/chrome/browser/" target="_blank">alternative browser</a>.</div><![endif]-->
<div class="p-body-header">
<div class="p-title ">
<h1 class="p-title-value">Pakistan Army Welfare Infrastructure Projects</h1>
</div>
<div class="p-description">
<ul class="listInline listInline--bullet">
<li>
<i class="fa--xf far fa-user" aria-hidden="true" title="Thread starter"></i>
<span class="u-srOnly">Thread starter</span>
<a href="/pdf/members/ghazi52.2675/" class="username  u-concealed" dir="auto" data-user-id="2675" data-xf-init="member-tooltip">ghazi52</a>
</li>
<li>
<i class="fa--xf far fa-clock" aria-hidden="true" title="Start date"></i>
<span class="u-srOnly">Start date</span>
<a href="/pdf/threads/pakistan-army-welfare-infrastructure-projects.707782/" class="u-concealed"><time class="u-dt" dir="auto" datetime="2021-04-16T22:47:10+0500" data-time="1618595230" data-date-string="Apr 16, 2021" data-time-string="10:47 PM" title="Apr 16, 2021 at 10:47 PM">Yesterday at 10:47 PM</time></a>
</li>
</ul>
</div>
</div>
<div class="p-body-main p-body-main--withSidebar ">
<div class="p-body-content">
<div class="p-body-pageContent">
<meta name="twitter:site" content="">
<div class="block block--messages" data-xf-init="" data-type="post" data-href="/pdf/inline-mod/">
<div class="block-outer"></div>
<div class="block-outer js-threadStatusField"></div>
<div class="block-container lbContainer" data-xf-init="lightbox select-to-quote" data-message-selector=".js-post" data-lb-id="thread-707782" data-lb-universal="1">
<div class="block-body js-replyNewMessageContainer">
<article class="message message--post js-post js-inlineModContainer  " data-author="ghazi52" data-content="post-13067609" id="js-post-13067609">
<span class="u-anchorTarget" id="post-13067609"></span>
<div class="message-inner">
<div class="message-cell message-cell--user">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar message-avatar--online">
<div class="message-avatar-wrapper">
<a href="/pdf/members/ghazi52.2675/" class="avatar avatar--m" data-user-id="2675" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/m/2/2675.jpg?1598295316" alt="ghazi52" class="avatar-u2675-m" itemprop="image" />
</a>
<span class="message-avatar-online" tabindex="0" data-xf-init="tooltip" data-trigger="auto" title="Online now"></span>
</div>
</div>
<div class="message-userDetails">
<div class="at_ni_label">
<span data-xf-init="tooltip" title="Thread Starter">
<i class="fa--xf far fa-feather-alt" aria-hidden="true"></i>
</span>
</div>
<h4 class="message-name"><a href="/pdf/members/ghazi52.2675/" class="username " dir="auto" data-user-id="2675" data-xf-init="member-tooltip" itemprop="name"><span class="username--style11">ghazi52</span></a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">PDF THINK TANK: ANALYST</h5>
</div>
<div class="message-userExtras">
<div class="message-userExtras__dpk-rank">
<img src="/pdf/styles/default/xenforo/ranks/FieldMarshal.jpg" />
</div>
<dl class="pairs pairs--justified">
<dt><span data-xf-init="tooltip" data-original-title="Joined"><i class="fa--xf far fa-calendar-check" aria-hidden="true"></i></span></dt>
<dd>Mar 21, 2007</dd>
</dl>
<dl class="pairs pairs--justified">
<dt><span data-xf-init="tooltip" data-original-title="Messages"><i class="fa--xf far fa-comments" aria-hidden="true"></i></span></dt>
<dd>57,246</dd>
</dl>
<dl class="pairs pairs--justified">
<dt><span data-xf-init="tooltip" data-original-title="Reaction score"><i class="fa--xf far fa-thumbs-up" aria-hidden="true"></i></span></dt>
<dd>56</dd>
</dl>
<dl class="pairs pairs--justified">
<dt><span data-xf-init="tooltip" data-original-title="Reactions received"><i class="fa--xf far fa-handshake" aria-hidden="true"></i></span></dt>
<dd class="rating-summary ">
<span class="rating-summary__count">
<a href="/pdf/members/ghazi52.2675/ratings?reaction_category_id=0" rel="nofollow" class="sv-rating-type-category0--text" title="Other 89,421" data-xf-click="overlay" data-cache="false">89,421</a>
</span>
</dd>
</dl>
<dl class="pairs pairs--justified message-userExtras__countryfg">
<dt>Country</dt>
<dd>
<img src="/pdf/styles/default/xenforo/flags2/pk.GIF" alt="Pakistan" title="Country: Pakistan" />
</dd>
</dl>
<dl class="pairs pairs--justified message-userExtras__locationfg">
<dt>Location</dt>
<dd>
<img src="/pdf/styles/default/xenforo/flags2/us.GIF" alt="United States" title="Location: United States" />
</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split">
<div class="message-attribution-main">
<a href="/pdf/threads/pakistan-army-welfare-infrastructure-projects.707782/post-13067609" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2021-04-16T22:47:10+0500" data-time="1618595230" data-date-string="Apr 16, 2021" data-time-string="10:47 PM" title="Apr 16, 2021 at 10:47 PM">Yesterday at 10:47 PM</time>
</a>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<li>
<a href="/pdf/threads/pakistan-army-welfare-infrastructure-projects.707782/post-13067609" data-xf-init="share-tooltip" data-href="/pdf/posts/13067609/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/pdf/threads/pakistan-army-welfare-infrastructure-projects.707782/post-13067609" rel="nofollow">
#1
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-13067609" data-lb-caption-desc="ghazi52 &middot; Apr 16, 2021 at 10:47 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Beautiful pictures of Army Public School Parachinar. Completed in year 2018. <br />
<br />
<br />
<div class="lbContainer lbContainer--inline " title="1618595136126.png" data-xf-init="lightbox" data-lb-single-image="1" data-lb-container-zoom="1" data-lb-trigger=".js-lbImage-attachment734697" data-lb-id="attachment734697">
<div class="lbContainer-zoomer js-lbImage-attachment734697" data-src="https://defence.pk/pdf/attachments/1618595136126-png.734697/" aria-label="Zoom"></div>
<img src="https://defence.pk/pdf/attachments/1618595136126-png.734697/" data-url="" class="bbImage" data-zoom-target="1" alt="1618595136126.png" style="width: 759px" />
</div>
<br />
<br />
<br />
<br />
<br />
<div class="lbContainer lbContainer--inline " title="1618595170329.png" data-xf-init="lightbox" data-lb-single-image="1" data-lb-container-zoom="1" data-lb-trigger=".js-lbImage-attachment734698" data-lb-id="attachment734698">
<div class="lbContainer-zoomer js-lbImage-attachment734698" data-src="https://defence.pk/pdf/attachments/1618595170329-png.734698/" aria-label="Zoom"></div>
<img src="https://defence.pk/pdf/attachments/1618595170329-png.734698/" data-url="" class="bbImage" data-zoom-target="1" alt="1618595170329.png" style="" />
</div>
<br />
<br />
<br />
<br />
<br />
<div class="lbContainer lbContainer--inline " title="1618595201891.png" data-xf-init="lightbox" data-lb-single-image="1" data-lb-container-zoom="1" data-lb-trigger=".js-lbImage-attachment734699" data-lb-id="attachment734699">
<div class="lbContainer-zoomer js-lbImage-attachment734699" data-src="https://defence.pk/pdf/attachments/1618595201891-png.734699/" aria-label="Zoom"></div>
<img src="https://defence.pk/pdf/attachments/1618595201891-png.734699/" data-url="" class="bbImage" data-zoom-target="1" alt="1618595201891.png" style="" />
</div>
<br />
<br />
<br />
<br />
<br />
<div class="lbContainer lbContainer--inline " title="1618595227521.png" data-xf-init="lightbox" data-lb-single-image="1" data-lb-container-zoom="1" data-lb-trigger=".js-lbImage-attachment734700" data-lb-id="attachment734700">
<div class="lbContainer-zoomer js-lbImage-attachment734700" data-src="https://defence.pk/pdf/attachments/1618595227521-png.734700/" aria-label="Zoom"></div>
<img src="https://defence.pk/pdf/attachments/1618595227521-png.734700/" data-url="" class="bbImage" data-zoom-target="1" alt="1618595227521.png" style="" />
</div></div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="sv-rating-bar sv-rating-bar--ratings-left js-ratingBar-post13067609 sv-rating-bar--under-controls ">
<ul class="sv-rating-bar__ratings">
<li class="sv-rating sv-rating--empty-list">
<a rel="nofollow" title="Like" rel="nofollow" data-cache="false">
<div class="sv-rating__icon">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="sv-rating-type-icon  sv-rating-type-icon1 sv-rating-type-icon--sprite sv-rating-type-icon--sprite1   sv-rating-type--small" alt="Like" title="Like" aria-hidden="true">
</div>
<div class="sv-rating__count">
Like:
1
</div>
</a>
</li>
</ul>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<div class="samCodeUnit" data-position="post_below_container_1"><div class="samItem"><center><div id='defence.pk_desktop_category1'></div></center></div></div>
<article class="message message--post js-post js-inlineModContainer  " data-author="ghazi52" data-content="post-13067730" id="js-post-13067730">
<span class="u-anchorTarget" id="post-13067730"></span>
<div class="message-inner">
<div class="message-cell message-cell--user">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar message-avatar--online">
<div class="message-avatar-wrapper">
<a href="/pdf/members/ghazi52.2675/" class="avatar avatar--m" data-user-id="2675" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/m/2/2675.jpg?1598295316" alt="ghazi52" class="avatar-u2675-m" itemprop="image" />
</a>
<span class="message-avatar-online" tabindex="0" data-xf-init="tooltip" data-trigger="auto" title="Online now"></span>
</div>
</div>
<div class="message-userDetails">
<div class="at_ni_label">
<span data-xf-init="tooltip" title="Thread Starter">
<i class="fa--xf far fa-feather-alt" aria-hidden="true"></i>
</span>
</div>
<h4 class="message-name"><a href="/pdf/members/ghazi52.2675/" class="username " dir="auto" data-user-id="2675" data-xf-init="member-tooltip" itemprop="name"><span class="username--style11">ghazi52</span></a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">PDF THINK TANK: ANALYST</h5>
</div>
<div class="message-userExtras">
<div class="message-userExtras__dpk-rank">
<img src="/pdf/styles/default/xenforo/ranks/FieldMarshal.jpg" />
</div>
<dl class="pairs pairs--justified">
<dt><span data-xf-init="tooltip" data-original-title="Joined"><i class="fa--xf far fa-calendar-check" aria-hidden="true"></i></span></dt>
<dd>Mar 21, 2007</dd>
</dl>
<dl class="pairs pairs--justified">
<dt><span data-xf-init="tooltip" data-original-title="Messages"><i class="fa--xf far fa-comments" aria-hidden="true"></i></span></dt>
<dd>57,246</dd>
</dl>
<dl class="pairs pairs--justified">
<dt><span data-xf-init="tooltip" data-original-title="Reaction score"><i class="fa--xf far fa-thumbs-up" aria-hidden="true"></i></span></dt>
<dd>56</dd>
</dl>
<dl class="pairs pairs--justified">
<dt><span data-xf-init="tooltip" data-original-title="Reactions received"><i class="fa--xf far fa-handshake" aria-hidden="true"></i></span></dt>
<dd class="rating-summary ">
<span class="rating-summary__count">
<a href="/pdf/members/ghazi52.2675/ratings?reaction_category_id=0" rel="nofollow" class="sv-rating-type-category0--text" title="Other 89,421" data-xf-click="overlay" data-cache="false">89,421</a>
</span>
</dd>
</dl>
<dl class="pairs pairs--justified message-userExtras__countryfg">
<dt>Country</dt>
<dd>
<img src="/pdf/styles/default/xenforo/flags2/pk.GIF" alt="Pakistan" title="Country: Pakistan" />
</dd>
</dl>
<dl class="pairs pairs--justified message-userExtras__locationfg">
<dt>Location</dt>
<dd>
<img src="/pdf/styles/default/xenforo/flags2/us.GIF" alt="United States" title="Location: United States" />
</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split">
<div class="message-attribution-main">
<a href="/pdf/threads/pakistan-army-welfare-infrastructure-projects.707782/post-13067730" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2021-04-17T00:11:36+0500" data-time="1618600296" data-date-string="Apr 17, 2021" data-time-string="12:11 AM" title="Apr 17, 2021 at 12:11 AM">38 minutes ago</time>
</a>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<li>
<a href="/pdf/threads/pakistan-army-welfare-infrastructure-projects.707782/post-13067730" data-xf-init="share-tooltip" data-href="/pdf/posts/13067730/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/pdf/threads/pakistan-army-welfare-infrastructure-projects.707782/post-13067730" rel="nofollow">
#2
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-13067730" data-lb-caption-desc="ghazi52 &middot; Apr 17, 2021 at 12:11 AM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Pakistan Army has built a girls school in place of TTP chief Hakeemullah Mehsud's headquarter.<br />
<br />
<br />
<div class="lbContainer lbContainer--inline " title="1618600233736.png" data-xf-init="lightbox" data-lb-single-image="1" data-lb-container-zoom="1" data-lb-trigger=".js-lbImage-attachment734723" data-lb-id="attachment734723">
<div class="lbContainer-zoomer js-lbImage-attachment734723" data-src="https://defence.pk/pdf/attachments/1618600233736-png.734723/" aria-label="Zoom"></div>
<img src="https://defence.pk/pdf/attachments/1618600233736-png.734723/" data-url="" class="bbImage" data-zoom-target="1" alt="1618600233736.png" style="" />
</div></div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="sv-rating-bar sv-rating-bar--ratings-left js-ratingBar-post13067730 sv-rating-bar--under-controls ">
<ul class="sv-rating-bar__ratings">

<li class="sv-rating sv-rating--empty-list">
<a rel="nofollow" title="Like" rel="nofollow" data-cache="false">
<div class="sv-rating__icon">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="sv-rating-type-icon  sv-rating-type-icon1 sv-rating-type-icon--sprite sv-rating-type-icon--sprite1   sv-rating-type--small" alt="Like" title="Like" aria-hidden="true">
</div>
<div class="sv-rating__count">
Like:
1
</div>
</a>
</li>
</ul>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<div class="samCodeUnit" data-position="post_below_container_2"><div class="samItem"><center><div id='defence.pk_desktop_category2'></div></center></div></div>
</div>
</div>
<div class="block-outer block-outer--after">
<div class="block-outer-opposite">
<a href="/pdf/login/" class="button--link button" data-xf-click="overlay"><span class="button-text">
You must log in or register to reply here.
</span></a>
</div>
</div>
</div>
<div class="block">
<div class="block-container block-userActivity">
<h3 class="block-header block-userActivity--header">
Users Who Are Viewing This Thread (Total: 3, Members: 0, Guests: 3)
</h3>
<div class="block-body">
<div class="block-row block-row--minor">
<ul class="listInline listInline--comma">
<li></li>
</ul>
</div>
</div>
</div>
</div>
<div class="block block--similarThreads" data-widget-id="34" data-widget-key="similar_threads" data-widget-definition="similar_threads">
<div class="block-container">
<h3 class="block-minorHeader">Similar threads</h3>
<div class="block-body">
<div class="structItemContainer-group js-threadList">
<div class="structItem structItem--thread js-inlineModContainer js-threadListItem-682454" data-author="KeyBORED Warrior">
<div class="structItem-cell structItem-cell--icon">
<div class="structItem-iconContainer">
<a href="/pdf/members/keybored-warrior.194741/" class="avatar avatar--s" data-user-id="194741" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/194/194741.jpg?1563081360" srcset="/pdf/data/avatars/m/194/194741.jpg?1563081360 2x" alt="KeyBORED Warrior" class="avatar-u194741-s" />
</a>
</div>
</div>
<div class="structItem-cell structItem-cell--main" data-xf-init="touch-proxy">
<div class="structItem-title">
<a href="/pdf/threads/the-pakistan-armys-belt-and-road-putsch-foreign-policy-mag.682454/" class="" data-tp-primary="on" data-xf-init="preview-tooltip" data-preview-url="/pdf/threads/the-pakistan-armys-belt-and-road-putsch-foreign-policy-mag.682454/preview">The Pakistan Army’s Belt and Road Putsch: FOREIGN POLICY MAG</a>
</div>
<div class="structItem-minor">
<ul class="structItem-parts">
<li><a href="/pdf/members/keybored-warrior.194741/" class="username " dir="auto" data-user-id="194741" data-xf-init="member-tooltip">KeyBORED Warrior</a></li>
<li class="structItem-startDate"><a href="/pdf/threads/the-pakistan-armys-belt-and-road-putsch-foreign-policy-mag.682454/" rel="nofollow"><time class="u-dt" dir="auto" datetime="2020-08-27T15:52:19+0500" data-time="1598525539" data-date-string="Aug 27, 2020" data-time-string="3:52 PM" title="Aug 27, 2020 at 3:52 PM">Aug 27, 2020</time></a></li>
</ul>
<span class="structItem-pageJump">
<a href="/pdf/threads/the-pakistan-armys-belt-and-road-putsch-foreign-policy-mag.682454/page-2">2</a>
<a href="/pdf/threads/the-pakistan-armys-belt-and-road-putsch-foreign-policy-mag.682454/page-3">3</a>
</span>
</div>
</div>
<div class="structItem-cell structItem-cell--meta" title="First message reaction score: 0">
<dl class="pairs pairs--justified">
<dt>Replies</dt>
<dd>42</dd>
</dl>
<dl class="pairs pairs--justified structItem-minor">
<dt>Views</dt>
<dd>2K</dd>
</dl>
</div>
<div class="structItem-cell structItem-cell--latest">
<a href="/pdf/threads/the-pakistan-armys-belt-and-road-putsch-foreign-policy-mag.682454/latest" rel="nofollow"><time class="structItem-latestDate u-dt" dir="auto" datetime="2020-09-21T07:07:06+0500" data-time="1600654026" data-date-string="Sep 21, 2020" data-time-string="7:07 AM" title="Sep 21, 2020 at 7:07 AM">Sep 21, 2020</time></a>
<div class="structItem-minor">
<a href="/pdf/members/nahtanbob.191633/" class="username " dir="auto" data-user-id="191633" data-xf-init="member-tooltip">nahtanbob</a>
</div>
</div>
<div class="structItem-cell structItem-cell--icon structItem-cell--iconEnd">
<div class="structItem-iconContainer">
<a href="/pdf/members/nahtanbob.191633/" class="avatar avatar--xxs avatar--default avatar--default--dynamic" data-user-id="191633" data-xf-init="member-tooltip" style="background-color: #333366; color: #8888c3">
<span class="avatar-u191633-s">N</span>
</a>
</div>
</div>
</div>
<div class="structItem structItem--thread js-inlineModContainer js-threadListItem-706676" data-author="Norwegian">
<div class="structItem-cell structItem-cell--icon">
<div class="structItem-iconContainer">
<a href="/pdf/members/norwegian.161346/" class="avatar avatar--s" data-user-id="161346" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/161/161346.jpg?1606867462" srcset="/pdf/data/avatars/m/161/161346.jpg?1606867462 2x" alt="Norwegian" class="avatar-u161346-s" />
</a>
</div>
</div>
<div class="structItem-cell structItem-cell--main" data-xf-init="touch-proxy">
<div class="structItem-title">
<a href="/pdf/threads/pakistans-geoeconomic-delusions.706676/" class="" data-tp-primary="on" data-xf-init="preview-tooltip" data-preview-url="/pdf/threads/pakistans-geoeconomic-delusions.706676/preview">Pakistan’s Geoeconomic Delusions</a>
</div>
<div class="structItem-minor">
<ul class="structItem-parts">
<li><a href="/pdf/members/norwegian.161346/" class="username " dir="auto" data-user-id="161346" data-xf-init="member-tooltip">Norwegian</a></li>
<li class="structItem-startDate"><a href="/pdf/threads/pakistans-geoeconomic-delusions.706676/" rel="nofollow"><time class="u-dt" dir="auto" datetime="2021-04-06T05:16:37+0500" data-time="1617668197" data-date-string="Apr 6, 2021" data-time-string="5:16 AM" title="Apr 6, 2021 at 5:16 AM">Apr 6, 2021</time></a></li>
</ul>
<span class="structItem-pageJump">
<a href="/pdf/threads/pakistans-geoeconomic-delusions.706676/page-2">2</a>
<a href="/pdf/threads/pakistans-geoeconomic-delusions.706676/page-3">3</a>
<a href="/pdf/threads/pakistans-geoeconomic-delusions.706676/page-4">4</a>
<a href="/pdf/threads/pakistans-geoeconomic-delusions.706676/page-5">5</a>
<a href="/pdf/threads/pakistans-geoeconomic-delusions.706676/page-6">6</a>
</span>
</div>
</div>
<div class="structItem-cell structItem-cell--meta" title="First message reaction score: 0">
<dl class="pairs pairs--justified">
<dt>Replies</dt>
<dd>76</dd>
</dl>
<dl class="pairs pairs--justified structItem-minor">
<dt>Views</dt>
<dd>3K</dd>
</dl>
</div>
<div class="structItem-cell structItem-cell--latest">
<a href="/pdf/threads/pakistans-geoeconomic-delusions.706676/latest" rel="nofollow"><time class="structItem-latestDate u-dt" dir="auto" datetime="2021-04-07T20:19:00+0500" data-time="1617808740" data-date-string="Apr 7, 2021" data-time-string="8:19 PM" title="Apr 7, 2021 at 8:19 PM">Apr 7, 2021</time></a>
<div class="structItem-minor">
<a href="/pdf/members/arsalan345.202019/" class="username " dir="auto" data-user-id="202019" data-xf-init="member-tooltip">Arsalan345</a>
</div>
</div>
<div class="structItem-cell structItem-cell--icon structItem-cell--iconEnd">
<div class="structItem-iconContainer">
<a href="/pdf/members/arsalan345.202019/" class="avatar avatar--xxs" data-user-id="202019" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/202/202019.jpg?1618027984" alt="Arsalan345" class="avatar-u202019-s" />
</a>
</div>
</div>
</div>
<div class="structItem structItem--thread js-inlineModContainer js-threadListItem-687495" data-author="Falcon26">
<div class="structItem-cell structItem-cell--icon">
<div class="structItem-iconContainer">
<a href="/pdf/members/falcon26.174240/" class="avatar avatar--s" data-user-id="174240" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/174/174240.jpg?1450951872" srcset="/pdf/data/avatars/m/174/174240.jpg?1450951872 2x" alt="Falcon26" class="avatar-u174240-s" />
</a>
</div>
</div>
<div class="structItem-cell structItem-cell--main" data-xf-init="touch-proxy">
<div class="structItem-title">
<a href="/pdf/threads/why-sialkot-is-a-model-of-export-oriented-growth-for-pakistan.687495/" class="" data-tp-primary="on" data-xf-init="preview-tooltip" data-preview-url="/pdf/threads/why-sialkot-is-a-model-of-export-oriented-growth-for-pakistan.687495/preview">Why Sialkot is a model of export oriented growth for Pakistan</a>
</div>
<div class="structItem-minor">
<ul class="structItem-parts">
<li><a href="/pdf/members/falcon26.174240/" class="username " dir="auto" data-user-id="174240" data-xf-init="member-tooltip">Falcon26</a></li>
<li class="structItem-startDate"><a href="/pdf/threads/why-sialkot-is-a-model-of-export-oriented-growth-for-pakistan.687495/" rel="nofollow"><time class="u-dt" dir="auto" datetime="2020-10-12T09:37:48+0500" data-time="1602477468" data-date-string="Oct 12, 2020" data-time-string="9:37 AM" title="Oct 12, 2020 at 9:37 AM">Oct 12, 2020</time></a></li>
</ul>
</div>
</div>
<div class="structItem-cell structItem-cell--meta" title="First message reaction score: 0">
<dl class="pairs pairs--justified">
<dt>Replies</dt>
<dd>7</dd>
</dl>
<dl class="pairs pairs--justified structItem-minor">
<dt>Views</dt>
<dd>624</dd>
</dl>
</div>
<div class="structItem-cell structItem-cell--latest">
<a href="/pdf/threads/why-sialkot-is-a-model-of-export-oriented-growth-for-pakistan.687495/latest" rel="nofollow"><time class="structItem-latestDate u-dt" dir="auto" datetime="2020-10-21T01:21:25+0500" data-time="1603225285" data-date-string="Oct 21, 2020" data-time-string="1:21 AM" title="Oct 21, 2020 at 1:21 AM">Oct 21, 2020</time></a>
<div class="structItem-minor">
<a href="/pdf/members/green-disc.186544/" class="username " dir="auto" data-user-id="186544" data-xf-init="member-tooltip">Green disc</a>
</div>
</div>
<div class="structItem-cell structItem-cell--icon structItem-cell--iconEnd">
<div class="structItem-iconContainer">
<a href="/pdf/members/green-disc.186544/" class="avatar avatar--xxs avatar--default avatar--default--dynamic" data-user-id="186544" data-xf-init="member-tooltip" style="background-color: #cc7033; color: #3d220f">
<span class="avatar-u186544-s">G</span>
</a>
</div>
</div>
</div>
<div class="structItem structItem--thread js-inlineModContainer js-threadListItem-673875" data-author="beijingwalker">
<div class="structItem-cell structItem-cell--icon">
<div class="structItem-iconContainer">
<a href="/pdf/members/beijingwalker.134467/" class="avatar avatar--s" data-user-id="134467" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/134/134467.jpg?1320406170" srcset="/pdf/data/avatars/m/134/134467.jpg?1320406170 2x" alt="beijingwalker" class="avatar-u134467-s" />
</a>
</div>
</div>
<div class="structItem-cell structItem-cell--main" data-xf-init="touch-proxy">
<div class="structItem-title">
<a href="/pdf/threads/terrorist-say-stock-exchange-attack-targeted-china-pakistan.673875/" class="" data-tp-primary="on" data-xf-init="preview-tooltip" data-preview-url="/pdf/threads/terrorist-say-stock-exchange-attack-targeted-china-pakistan.673875/preview">Terrorist say stock exchange attack targeted China, Pakistan</a>
</div>
<div class="structItem-minor">
<ul class="structItem-parts">
<li><a href="/pdf/members/beijingwalker.134467/" class="username " dir="auto" data-user-id="134467" data-xf-init="member-tooltip">beijingwalker</a></li>
<li class="structItem-startDate"><a href="/pdf/threads/terrorist-say-stock-exchange-attack-targeted-china-pakistan.673875/" rel="nofollow"><time class="u-dt" dir="auto" datetime="2020-06-30T19:39:22+0500" data-time="1593527962" data-date-string="Jun 30, 2020" data-time-string="7:39 PM" title="Jun 30, 2020 at 7:39 PM">Jun 30, 2020</time></a></li>
</ul>
<span class="structItem-pageJump">
<a href="/pdf/threads/terrorist-say-stock-exchange-attack-targeted-china-pakistan.673875/page-2">2</a>
<a href="/pdf/threads/terrorist-say-stock-exchange-attack-targeted-china-pakistan.673875/page-3">3</a>
</span>
</div>
</div>
<div class="structItem-cell structItem-cell--meta" title="First message reaction score: 1">
<dl class="pairs pairs--justified">
<dt>Replies</dt>
<dd>36</dd>
</dl>
<dl class="pairs pairs--justified structItem-minor">
<dt>Views</dt>
<dd>2K</dd>
</dl>
</div>
<div class="structItem-cell structItem-cell--latest">
<a href="/pdf/threads/terrorist-say-stock-exchange-attack-targeted-china-pakistan.673875/latest" rel="nofollow"><time class="structItem-latestDate u-dt" dir="auto" datetime="2020-06-30T21:26:42+0500" data-time="1593534402" data-date-string="Jun 30, 2020" data-time-string="9:26 PM" title="Jun 30, 2020 at 9:26 PM">Jun 30, 2020</time></a>
<div class="structItem-minor">
<a href="/pdf/members/areesh.25703/" class="username " dir="auto" data-user-id="25703" data-xf-init="member-tooltip">Areesh</a>
</div>
</div>
<div class="structItem-cell structItem-cell--icon structItem-cell--iconEnd">
<div class="structItem-iconContainer">
<a href="/pdf/members/areesh.25703/" class="avatar avatar--xxs" data-user-id="25703" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/25/25703.jpg?1607857897" alt="Areesh" class="avatar-u25703-s" />
</a>
</div>
</div>
</div>
<div class="structItem structItem--thread js-inlineModContainer js-threadListItem-663194" data-author="Orca">
<div class="structItem-cell structItem-cell--icon">
<div class="structItem-iconContainer">
<a href="/pdf/members/orca.181317/" class="avatar avatar--s" data-user-id="181317" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/181/181317.jpg?1546854538" srcset="/pdf/data/avatars/m/181/181317.jpg?1546854538 2x" alt="Orca" class="avatar-u181317-s" />
</a>
</div>
</div>
<div class="structItem-cell structItem-cell--main" data-xf-init="touch-proxy">
<div class="structItem-title">
<a href="/pdf/threads/how-the-united-states-should-deal-with-china-in-pakistan.663194/" class="" data-tp-primary="on" data-xf-init="preview-tooltip" data-preview-url="/pdf/threads/how-the-united-states-should-deal-with-china-in-pakistan.663194/preview">How the United States Should Deal With China in Pakistan</a>
</div>
<div class="structItem-minor">
<ul class="structItem-parts">
<li><a href="/pdf/members/orca.181317/" class="username " dir="auto" data-user-id="181317" data-xf-init="member-tooltip">Orca</a></li>
<li class="structItem-startDate"><a href="/pdf/threads/how-the-united-states-should-deal-with-china-in-pakistan.663194/" rel="nofollow"><time class="u-dt" dir="auto" datetime="2020-04-26T12:19:48+0500" data-time="1587885588" data-date-string="Apr 26, 2020" data-time-string="12:19 PM" title="Apr 26, 2020 at 12:19 PM">Apr 26, 2020</time></a></li>
</ul>
</div>
</div>
<div class="structItem-cell structItem-cell--meta" title="First message reaction score: 1">
<dl class="pairs pairs--justified">
<dt>Replies</dt>
<dd>7</dd>
</dl>
<dl class="pairs pairs--justified structItem-minor">
<dt>Views</dt>
<dd>1K</dd>
</dl>
</div>
<div class="structItem-cell structItem-cell--latest">
<a href="/pdf/threads/how-the-united-states-should-deal-with-china-in-pakistan.663194/latest" rel="nofollow"><time class="structItem-latestDate u-dt" dir="auto" datetime="2020-04-26T16:32:50+0500" data-time="1587900770" data-date-string="Apr 26, 2020" data-time-string="4:32 PM" title="Apr 26, 2020 at 4:32 PM">Apr 26, 2020</time></a>
<div class="structItem-minor">
<a href="/pdf/members/leviza.31501/" class="username " dir="auto" data-user-id="31501" data-xf-init="member-tooltip">Leviza</a>
</div>
</div>
<div class="structItem-cell structItem-cell--icon structItem-cell--iconEnd">
<div class="structItem-iconContainer">
<a href="/pdf/members/leviza.31501/" class="avatar avatar--xxs" data-user-id="31501" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/31/31501.jpg?1385659303" alt="Leviza" class="avatar-u31501-s" />
</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="blockMessage blockMessage--none">
<div class="shareButtons shareButtons--iconic" data-xf-init="share-buttons" data-page-url="" data-page-title="" data-page-desc="">
<span class="shareButtons-label">Share:</span>
<div class="shareButtons-buttons">
<a class="shareButtons-button shareButtons-button--brand shareButtons-button--reddit" data-href="https://reddit.com/submit?url={url}&amp;title={title}">
<i aria-hidden="true"></i>
<span>Reddit</span>
</a>
<a class="shareButtons-button shareButtons-button--brand shareButtons-button--pinterest" data-href="https://pinterest.com/pin/create/bookmarklet/?url={url}&amp;description={title}&amp;media={image}">
<i aria-hidden="true"></i>
<span>Pinterest</span>
</a>
<a class="shareButtons-button shareButtons-button--brand shareButtons-button--tumblr" data-href="https://www.tumblr.com/widgets/share/tool?canonicalUrl={url}&amp;title={title}">
<i aria-hidden="true"></i>
<span>Tumblr</span>
</a>
<a class="shareButtons-button shareButtons-button--brand shareButtons-button--whatsApp" data-href="https://api.whatsapp.com/send?text={title}&nbsp;{url}">
<i aria-hidden="true"></i>
<span>WhatsApp</span>
</a>
<a class="shareButtons-button shareButtons-button--email" data-href="mailto:?subject={title}&amp;body={url}">
<i aria-hidden="true"></i>
<span>Email</span>
</a>
<a class="shareButtons-button shareButtons-button--link is-hidden" data-clipboard="{url}">
<i aria-hidden="true"></i>
<span>Link</span>
</a>
</div>
</div>
</div>
</div>
</div>
<div class="p-body-sidebar">
<center><div id='defence.pk_desktop_sidebar'></div></center>
<br />
<div class="block" data-widget-id="9" data-widget-key="forum_overview_new_posts" data-widget-definition="new_posts">
<div class="block-container">
<h3 class="block-minorHeader">
<a href="/pdf/whats-new/posts/?skip=1" rel="nofollow">Latest posts</a>
</h3>
<ul class="block-body">
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/muhammed45.172471/" class="avatar avatar--xxs" data-user-id="172471" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/172/172471.jpg?1613123886" alt="Muhammed45" class="avatar-u172471-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/islamic-emirate-in-afghanistan-is-an-existential-threat-to-pakistan-and-national-security-threat-to-iran-and-india-iranian-foreign-minister.707758/post-13067797">Islamic emirate in Afghanistan is an existential threat to Pakistan and national security threat to Iran and India: Iranian Foreign Minister</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: Muhammed45</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:49:07+0500" data-time="1618602547" data-date-string="Apr 17, 2021" data-time-string="12:49 AM" title="Apr 17, 2021 at 12:49 AM">1 minute ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/central-south-asia.160/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Central &amp; South Asia
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/ghazi52.2675/" class="avatar avatar--xxs" data-user-id="2675" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/2/2675.jpg?1598295316" alt="ghazi52" class="avatar-u2675-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/stupid-funny-from-around-the-world-continued.397229/post-13067796">Stupid &amp; Funny from Around the World :Continued</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: ghazi52</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:48:05+0500" data-time="1618602485" data-date-string="Apr 17, 2021" data-time-string="12:48 AM" title="Apr 17, 2021 at 12:48 AM">2 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/general-photos-multimedia.76/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
General Photos &amp; Multimedia
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/f-7.182739/" class="avatar avatar--xxs" data-user-id="182739" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/182/182739.jpg?1486489025" alt="F-7" class="avatar-u182739-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/3-story-roller-coaster-bridge-in-china.707790/post-13067793">3 Story Roller Coaster Bridge In China</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: F-7</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:46:25+0500" data-time="1618602385" data-date-string="Apr 17, 2021" data-time-string="12:46 AM" title="Apr 17, 2021 at 12:46 AM">3 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/general-photos-multimedia.76/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
General Photos &amp; Multimedia
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/flowerfan2020.198551/" class="avatar avatar--xxs avatar--default avatar--default--dynamic" data-user-id="198551" data-xf-init="member-tooltip" style="background-color: #cc6666; color: #602020">
<span class="avatar-u198551-s">F</span>
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/china-ranks-first-in-ai-patent-applications-7-2-times-more-than-us.707771/post-13067792">China ranks first in AI patent applications, 7.2 times more than US</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: flowerfan2020</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:46:00+0500" data-time="1618602360" data-date-string="Apr 17, 2021" data-time-string="12:46 AM" title="Apr 17, 2021 at 12:46 AM">4 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/china-far-east.161/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
China &amp; Far East
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/arian.134109/" class="avatar avatar--xxs" data-user-id="134109" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/134/134109.jpg?1342482698" alt="Arian" class="avatar-u134109-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/iran-starts-60-uranium-enrichment.707491/post-13067791">Iran Starts 60% Uranium Enrichment</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: Arian</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:44:27+0500" data-time="1618602267" data-date-string="Apr 17, 2021" data-time-string="12:44 AM" title="Apr 17, 2021 at 12:44 AM">5 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/iranian-defence-forum.152/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Iranian Defence Forum
</span>
</span>
</a>
</div>
</div>
</div>
</li>
</ul>
</div>
</div>
<div class="block" data-widget-id="16" data-widget-key="pd_lat_posts" data-widget-definition="new_posts">
<div class="block-container">
<h3 class="block-minorHeader">
<a href="/pdf/whats-new/posts/?skip=1" rel="nofollow">Pakistan Defence Latest Posts</a>
</h3>
<ul class="block-body">
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/ghazi52.2675/" class="avatar avatar--xxs" data-user-id="2675" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/2/2675.jpg?1598295316" alt="ghazi52" class="avatar-u2675-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/pakistan-army-welfare-infrastructure-projects.707782/post-13067730">Pakistan Army Welfare Infrastructure Projects</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: ghazi52</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:11:36+0500" data-time="1618600296" data-date-string="Apr 17, 2021" data-time-string="12:11 AM" title="Apr 17, 2021 at 12:11 AM">38 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/pakistan-army.13/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Pakistan Army
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/goritoes.201781/" class="avatar avatar--xxs" data-user-id="201781" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/201/201781.jpg?1611186860" alt="Goritoes" class="avatar-u201781-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/pakistan-deploying-unmanned-ground-vehicles-near-indian-border-media-reports.676756/post-13067724"><span class="label label--green" dir="auto">Featured</span><span class="label-append">&nbsp;</span>Pakistan Deploying Unmanned Ground Vehicles Near Indian Border: Media Reports</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: Goritoes</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:09:23+0500" data-time="1618600163" data-date-string="Apr 17, 2021" data-time-string="12:09 AM" title="Apr 17, 2021 at 12:09 AM">41 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/pakistan-army.13/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Pakistan Army
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/ilion12345_1.176107/" class="avatar avatar--xxs" data-user-id="176107" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/176/176107.jpg?1555485916" alt="iLION12345_1" class="avatar-u176107-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/mechanised-divisions-pakistan-army.529460/post-13067684">Mechanised Divisions Pakistan Army</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: iLION12345_1</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-16T23:32:40+0500" data-time="1618597960" data-date-string="Apr 16, 2021" data-time-string="11:32 PM" title="Apr 16, 2021 at 11:32 PM">Yesterday at 11:32 PM</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/pakistan-army.13/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Pakistan Army
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/bhola-record.200275/" class="avatar avatar--xxs" data-user-id="200275" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/200/200275.jpg?1595512828" alt="bhola record" class="avatar-u200275-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/operation-zulfiqar-sahiwal-tragedy.601383/post-13067675">Operation Zulfiqar &amp; Sahiwal Tragedy.</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: bhola record</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-16T23:23:04+0500" data-time="1618597384" data-date-string="Apr 16, 2021" data-time-string="11:23 PM" title="Apr 16, 2021 at 11:23 PM">Yesterday at 11:23 PM</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/pakistans-internal-security.87/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Pakistan&#039;s Internal Security
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/eversoris.28958/" class="avatar avatar--xxs" data-user-id="28958" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/28/28958.jpg?1276980498" alt="Eversoris" class="avatar-u28958-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/the-americans-wonder-why-did-india-put-aging-mig-21-jets-on-the-front-lines-with-pakistan.681106/post-13067543">The Americans wonder: Why Did India Put Aging MiG-21 Jets on the Front Lines With Pakistan?</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: Eversoris</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-16T21:59:07+0500" data-time="1618592347" data-date-string="Apr 16, 2021" data-time-string="9:59 PM" title="Apr 16, 2021 at 9:59 PM">Yesterday at 9:59 PM</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/pakistan-air-force.12/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Pakistan Air Force
</span>
</span>
</a>
</div>
</div>
</div>
</li>
</ul>
</div>
</div>
<div class="block" data-widget-id="17" data-widget-key="pa_lat_posts" data-widget-definition="new_posts">
<div class="block-container">
<h3 class="block-minorHeader">
<a href="/pdf/whats-new/posts/?skip=1" rel="nofollow">Pakistan Affairs Latest Posts</a>
</h3>
<ul class="block-body">
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/ghazi52.2675/" class="avatar avatar--xxs" data-user-id="2675" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/2/2675.jpg?1598295316" alt="ghazi52" class="avatar-u2675-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/brain-autopsy-of-a-n-league-voter.705851/post-13067788">Brain autopsy of a N league voter</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: ghazi52</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:40:17+0500" data-time="1618602017" data-date-string="Apr 17, 2021" data-time-string="12:40 AM" title="Apr 17, 2021 at 12:40 AM">10 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/pakistani-siasat.82/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Pakistani Siasat
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/hakikat-ve-hikmet.190933/" class="avatar avatar--xxs" data-user-id="190933" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/190/190933.jpg?1533100973" alt="Hakikat ve Hikmet" class="avatar-u190933-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/bidens-afghan-pullout-is-a-victory-for-pakistan-but-at-what-cost.707768/post-13067785">Biden’s Afghan Pullout Is a Victory for Pakistan. But at What Cost?</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: Hakikat ve Hikmet</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:37:52+0500" data-time="1618601872" data-date-string="Apr 17, 2021" data-time-string="12:37 AM" title="Apr 17, 2021 at 12:37 AM">12 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/strategic-foreign-affairs.10/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Strategic &amp; Foreign Affairs
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/khan-vilatey.198485/" class="avatar avatar--xxs avatar--default avatar--default--dynamic" data-user-id="198485" data-xf-init="member-tooltip" style="background-color: #331452; color: #8c47d1">
<span class="avatar-u198485-s">K</span>
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/indian-concerned-about-biden-statement-americans-to-pull-out-of-afghanistan-till-sept-2021.707659/post-13067784">Indian concerned about Biden statement- Americans to pull out of Afghanistan till Sept 2021</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: Khan vilatey</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:36:53+0500" data-time="1618601813" data-date-string="Apr 17, 2021" data-time-string="12:36 AM" title="Apr 17, 2021 at 12:36 AM">13 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/strategic-foreign-affairs.10/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Strategic &amp; Foreign Affairs
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/jamd.167882/" class="avatar avatar--xxs" data-user-id="167882" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/167/167882.jpg?1467086396" alt="JamD" class="avatar-u167882-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/how-can-pakistan-have-a-robust-and-free-foreign-policy.707747/post-13067746">How can Pakistan have a robust and free foreign policy?</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: JamD</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:16:20+0500" data-time="1618600580" data-date-string="Apr 17, 2021" data-time-string="12:16 AM" title="Apr 17, 2021 at 12:16 AM">34 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/strategic-foreign-affairs.10/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Strategic &amp; Foreign Affairs
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/hiptullha.154718/" class="avatar avatar--xxs" data-user-id="154718" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/154/154718.jpg?1574050882" alt="Hiptullha" class="avatar-u154718-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/all-us-troops-to-leave-afghanistan-by-september-11-2021.707508/post-13067744">All US troops to leave Afghanistan by September 11, 2021</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: Hiptullha</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:15:36+0500" data-time="1618600536" data-date-string="Apr 17, 2021" data-time-string="12:15 AM" title="Apr 17, 2021 at 12:15 AM">34 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/strategic-foreign-affairs.10/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Strategic &amp; Foreign Affairs
</span>
</span>
</a>
</div>
</div>
</div>
</li>
</ul>
</div>
</div>
<div class="block" data-widget-id="18" data-widget-key="mf_lat_posts" data-widget-definition="new_posts">
<div class="block-container">
<h3 class="block-minorHeader">
<a href="/pdf/whats-new/posts/?skip=1" rel="nofollow">Military Forum Latest Posts</a>
</h3>
<ul class="block-body">
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/siegecrossbow.31334/" class="avatar avatar--xxs" data-user-id="31334" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/31/31334.jpg?1541508549" alt="siegecrossbow" class="avatar-u31334-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/us-f-15-gets-longest-a2a-kill-shot.707704/post-13067661">Us F-15 gets longest A2A kill shot</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: siegecrossbow</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-16T23:14:44+0500" data-time="1618596884" data-date-string="Apr 16, 2021" data-time-string="11:14 PM" title="Apr 16, 2021 at 11:14 PM">Yesterday at 11:14 PM</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/air-warfare.153/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Air Warfare
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/vapour.200076/" class="avatar avatar--xxs" data-user-id="200076" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/200/200076.jpg?1599295010" alt="Vapour" class="avatar-u200076-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/cyber-weapons-of-mass-destruction.707717/post-13067582">Cyber Weapons of Mass Destruction</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: Vapour</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-16T22:30:11+0500" data-time="1618594211" data-date-string="Apr 16, 2021" data-time-string="10:30 PM" title="Apr 16, 2021 at 10:30 PM">Yesterday at 10:30 PM</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/military-forum.85/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Military Forum
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/straightedge.201789/" class="avatar avatar--xxs avatar--default avatar--default--dynamic" data-user-id="201789" data-xf-init="member-tooltip" style="background-color: #d65cd6; color: #661a66">
<span class="avatar-u201789-s">S</span>
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/inappropriate-naval-launch-dance-performance-attracts-widespread-criticism.707677/post-13067118">&#039;Inappropriate&#039; naval launch dance performance attracts widespread criticism</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: StraightEdge</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-16T18:18:48+0500" data-time="1618579128" data-date-string="Apr 16, 2021" data-time-string="6:18 PM" title="Apr 16, 2021 at 6:18 PM">Yesterday at 6:18 PM</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/military-forum.85/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Military Forum
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/zarvan.38934/" class="avatar avatar--xxs" data-user-id="38934" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/38/38934.jpg?1618556447" alt="Zarvan" class="avatar-u38934-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/opv-87-a-r-a-piedrabuena-handed-over-to-argentine-navy.707728/post-13066499">OPV 87 A.R.A. Piedrabuena Handed Over To Argentine Navy</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: Zarvan</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-16T12:10:10+0500" data-time="1618557010" data-date-string="Apr 16, 2021" data-time-string="12:10 PM" title="Apr 16, 2021 at 12:10 PM">Yesterday at 12:10 PM</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/naval-warfare.158/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Naval Warfare
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/zarvan.38934/" class="avatar avatar--xxs" data-user-id="38934" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/38/38934.jpg?1618556447" alt="Zarvan" class="avatar-u38934-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/u-s-french-carrier-strike-groups-conduct-dual-carrier-operations.707727/post-13066496">U.S., French Carrier Strike Groups Conduct Dual Carrier Operations</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: Zarvan</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-16T12:04:52+0500" data-time="1618556692" data-date-string="Apr 16, 2021" data-time-string="12:04 PM" title="Apr 16, 2021 at 12:04 PM">Yesterday at 12:04 PM</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/naval-warfare.158/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Naval Warfare
</span>
</span>
</a>
</div>
</div>
</div>
</li>
</ul>
</div>
</div>
<div class="block" data-widget-id="20" data-widget-key="cd_lat_posts" data-widget-definition="new_posts">
<div class="block-container">
<h3 class="block-minorHeader">
<a href="/pdf/whats-new/posts/?skip=1" rel="nofollow">Country Latest Posts</a>
</h3>
<ul class="block-body">
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/arian.134109/" class="avatar avatar--xxs" data-user-id="134109" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/134/134109.jpg?1342482698" alt="Arian" class="avatar-u134109-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/iran-starts-60-uranium-enrichment.707491/post-13067791">Iran Starts 60% Uranium Enrichment</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: Arian</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:44:27+0500" data-time="1618602267" data-date-string="Apr 17, 2021" data-time-string="12:44 AM" title="Apr 17, 2021 at 12:44 AM">5 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/iranian-defence-forum.152/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Iranian Defence Forum
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/straightedge.201789/" class="avatar avatar--xxs avatar--default avatar--default--dynamic" data-user-id="201789" data-xf-init="member-tooltip" style="background-color: #d65cd6; color: #661a66">
<span class="avatar-u201789-s">S</span>
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/bsf-shoots-indian-youth-trying-to-enter-bangladesh-illegally.707276/post-13067783">BSF shoots Indian youth trying to enter Bangladesh illegally</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: StraightEdge</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:36:07+0500" data-time="1618601767" data-date-string="Apr 17, 2021" data-time-string="12:36 AM" title="Apr 17, 2021 at 12:36 AM">14 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/bangladesh-defence-forum.92/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Bangladesh Defence Forum
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/lord-of-gondor.29709/" class="avatar avatar--xxs" data-user-id="29709" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/29/29709.jpg?1596311882" alt="Lord Of Gondor" class="avatar-u29709-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/indian-special-forces.43257/post-13067780">Indian Special Forces</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: Lord Of Gondor</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:33:14+0500" data-time="1618601594" data-date-string="Apr 17, 2021" data-time-string="12:33 AM" title="Apr 17, 2021 at 12:33 AM">17 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/indian-defence-forum.52/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Indian Defence Forum
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/rent4country.200358/" class="avatar avatar--xxs" data-user-id="200358" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/200/200358.jpg?1598146598" alt="rent4country" class="avatar-u200358-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/chinas-shove-and-push-tactic-did-not-work-with-india-we-got-international-support-cds-gen-bipin-rawat.707682/post-13067729">China&#039;s &#039;shove and push&#039; tactic did not work with India, we got international support: CDS Gen Bipin Rawat</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: rent4country</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:11:16+0500" data-time="1618600276" data-date-string="Apr 17, 2021" data-time-string="12:11 AM" title="Apr 17, 2021 at 12:11 AM">39 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/indian-defence-forum.52/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Indian Defence Forum
</span>
</span>
</a>
</div>
</div>
</div>
</li>
<li class="block-row">
<div class="contentRow">
<div class="contentRow-figure">
<a href="/pdf/members/dalalermanodi.199656/" class="avatar avatar--xxs" data-user-id="199656" data-xf-init="member-tooltip">
<img src="/pdf/data/avatars/s/199/199656.jpg?1606060013" alt="DalalErMaNodi" class="avatar-u199656-s" />
</a>
</div>
<div class="contentRow-main contentRow-main--close">
<a href="/pdf/threads/bangladesh-islamist-orator-rofiqul-madani-sued-over-pornography.707623/post-13067716">Bangladesh Islamist orator Rofiqul Madani sued over pornography</a>
<div class="contentRow-minor contentRow-minor--hideLinks">
<ul class="listInline listInline--bullet">
<li>Latest: DalalErMaNodi</li>
<li><time class="u-dt" dir="auto" datetime="2021-04-17T00:02:46+0500" data-time="1618599766" data-date-string="Apr 17, 2021" data-time-string="12:02 AM" title="Apr 17, 2021 at 12:02 AM">47 minutes ago</time></li>
</ul>
</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<a href="/pdf/forums/bangladesh-defence-forum.92/">
<span class="iconic-label">
<span class="label label--ajaxCustom" style="">
Bangladesh Defence Forum
</span>
</span>
</a>
</div>
</div>
</div>
</li>
</ul>
</div>
</div>
</div>
</div>
<div class="p-breadcrumbs-wrap p-breadcrumbs-wrap--bottom">
<ul class="p-breadcrumbs p-breadcrumbs--bottom" itemscope itemtype="https://schema.org/BreadcrumbList">
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="https://defence.pk" itemprop="item">
<span itemprop="name">Home</span>
</a>
<meta itemprop="position" content="1" />
</li>
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="/pdf/" itemprop="item">
<span itemprop="name">Forums</span>
</a>
<meta itemprop="position" content="2" />
</li>
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="/pdf/#pakistan-defence-military-forums.3" itemprop="item">
<span itemprop="name">Pakistan Defence &amp; Military Forums</span>
</a>
<meta itemprop="position" content="3" />
</li>
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="/pdf/forums/pakistan-army.13/" itemprop="item">
<span itemprop="name">Pakistan Army</span>
</a>
<meta itemprop="position" content="4" />
</li>
</ul>
</div>
<div class="samCodeUnit" data-position="container_breadcrumb_bottom_below"><div class="samItem"><center><div id='defence.pk_desktop_banner'></div></center></div></div>
</div>
</div>
</div> 
<footer class="p-footer" id="footer">
<div class='pdf-footer-padding'>
<div class='pdf-footer'>
<div class='pdf-footer__1'>
<img src="/pdf/styles/xenfocus/pakistan-defence/logo.png" alt='' />
</div>
<div class='pdf-footer__2'>
<h3>About Us</h3>
<p>Defence.pk is a one stop resource for Pakistan defence, strategic affairs, security issues, world defence and military affairs.</p>
<p>Contact us: <a href="mailto:contact@defence.pk">contact@defence.pk</a></p>
</div>
</div>
</div>
<div class="p-footer-inner">
<div class="p-footer-row">
<div class="p-footer-row-main">
<ul class="p-footer-linkList">
<li class='xenfocus-footer-icon'><a href="#" rel="nofollow" data-xf-init="tooltip" title="Customize" data-xenfocus-editor><i class="fa--xf far fa-toggle-on" aria-hidden="true"></i></a></li>
</ul>
</div>
<div class="p-footer-row-opposite">
<ul class="p-footer-linkList">
<li><a href="/pdf/misc/contact" data-xf-click="overlay">Contact us</a></li>
<li><a href="/pdf/help/terms/">Terms and rules</a></li>
<li><a href="/pdf/help/privacy-policy/">Privacy policy</a></li>
<li><a href="/pdf/help/">Help</a></li>
<li><a href="https://defence.pk">Home</a></li>
<li><a href="/pdf/forums/-/index.rss" target="_blank" class="p-footer-rssLink" title="RSS"><span aria-hidden="true"><i class="fa--xf far fa-rss" aria-hidden="true"></i><span class="u-srOnly">RSS</span></span></a></li>
</ul>
</div>
</div>
<div class='footer-align'>
<div>
</div>
<div>
<ul class='xenfocus-social'>
<li><a href='https://www.facebook.com/pakistanidefence/' target='_blank'></a></li>
<li><a href='https://www.instagram.com/defencepk/' target='_blank'></a></li>
<li><a href='https://twitter.com/defence_pk' target='_blank'></a></li>
<li><a href='https://play.google.com/store/apps/details?id=com.tapatalk.defencepkforums&hl=en_US' target='_blank'></a></li>
</ul>
</div>
</div>
</div>
</footer>

<div class="offCanvasMenu offCanvasMenu--nav js-headerOffCanvasMenu" data-menu="menu" aria-hidden="true" data-ocm-builder="navigation">
<div class="offCanvasMenu-backdrop" data-menu-close="true"></div>
<div class="offCanvasMenu-content">
<div class="offCanvasMenu-header">
Menu
<a class="offCanvasMenu-closer" data-menu-close="true" role="button" tabindex="0" aria-label="Close"></a>
</div>
<div class="p-offCanvasRegisterLink">
<div class="offCanvasMenu-linkHolder">
<a href="/pdf/login/" class="offCanvasMenu-link" rel="nofollow" data-xf-click="overlay" data-menu-close="true">
Log in
</a>
</div>
<hr class="offCanvasMenu-separator" />
<div class="offCanvasMenu-linkHolder">
<a href="/pdf/register/" class="offCanvasMenu-link" rel="nofollow" data-xf-click="overlay" data-menu-close="true">
Register
</a>
</div>
<hr class="offCanvasMenu-separator" />
</div>
<div class="js-offCanvasNavTarget"></div>
</div>
</div>

</div> 
</div> 
<div class='focus-editor-wrap'>
<div class='focus-editor-overlay' data-xenfocus-editor></div>
<div class='focus-editor'>
<div class='focus-editor-scroll'>
<div>
<div class='focus-editor__title' data-focus-text='Customize layout'></div>
<div class='focus-editor-panel' data-setting='focus-mobile-navigation-bar' data-setting-default='on'>
<div class='focus-editor-toggle'><i class='focus-toggle'><i></i></i></div>
<div class='focus-editor-text' data-setting-title='Mobile navigation bar?' data-setting-desc='Display a navigation bar at the bottom of the site when using a mobile device?'></div>
</div>
<div class='focus-editor-panel' data-setting='focus-fluid' data-setting-default='off'>
<div class='focus-editor-toggle'><i class='focus-toggle'><i></i></i></div>
<div class='focus-editor-text' data-setting-title='Fluid width?' data-setting-desc='Enabling this will increase the width of the site so it occupies the width of your browser. Useful for larger screens.'></div>
</div>
<div class='focus-editor-panel' data-setting='focus-grid' data-setting-default='on'>
<div class='focus-editor-toggle'><i class='focus-toggle'><i></i></i></div>
<div class='focus-editor-text' data-setting-title='Grid layout?' data-setting-desc='If enabled, the forums will be displayed as a grid instead of a table.'></div>
</div>
<div class='focus-editor-panel' data-setting='focus-sidebar-sticky' data-setting-default='on'>
<div class='focus-editor-toggle'><i class='focus-toggle'><i></i></i></div>
<div class='focus-editor-text' data-setting-title='Sticky sidebar?' data-setting-desc='If enabled, the sidebar will stick to the top of the screen for easy access.'></div>
</div>
<div class='focus-editor-panel' data-setting='focus-sidebar-flip' data-setting-default='off'>
<div class='focus-editor-toggle'><i class='focus-toggle'><i></i></i></div>
<div class='focus-editor-text' data-setting-title='Flip sidebar?' data-setting-desc='Flip the sidebar between the left and right sides.'></div>
</div>
</div>
</div>
<div class='focus-editor-save'>
<button data-xenfocus-editor data-focus-text='Save'></button>
</div>
</div>
</div>
<div class="u-bottomFixer js-bottomFixTarget">
</div>
<div class="u-scrollButtons js-scrollButtons" data-trigger-type="both">
<a href="#top" class="button--scroll button" data-xf-click="scroll-to"><span class="button-text"><i class="fa--xf far fa-arrow-up" aria-hidden="true"></i><span class="u-srOnly">Top</span></span></a>
<a href="#footer" class="button--scroll button" data-xf-click="scroll-to"><span class="button-text"><i class="fa--xf far fa-arrow-down" aria-hidden="true"></i><span class="u-srOnly">Bottom</span></span></a>
</div>
<script src="/pdf/js/vendor/jquery/jquery-3.4.1.min.js?_v=fe23bc1f"></script>
<script src="/pdf/js/vendor/vendor-compiled.js?_v=fe23bc1f"></script>
<script src="/pdf/js/xf/core-compiled.js?_v=fe23bc1f"></script>
<script>
		XF.samAdBlockAction = "message";
		XF.samSupportUsTitle = "Please support us";
		XF.samSupportUsMessage = "Please support us by disabling AdBlocker on our website.";
		XF.samSupportRedirectUrl = '';
		XF.samAdBlockNotice = {
			element: '.p-body-content',
			method: 'prepend',
			content: '<h1>ADs support the running of this site. Please disable.<\/h1>'
		};
		$(function() {
			 function getIgnoredContentHeight(ad) {
				  var adminActions = ad.find('.samAdminActions');
				  var ignoreContent = ad.find('.samIgnoreContent');
				  var ignoredHeight = 0;
				  if (adminActions.length) {
					   ignoredHeight += adminActions.height();
				  }
				  if (ignoreContent.length) {
					   ignoredHeight += ignoreContent.height();
				  }
				  return ignoredHeight;
			 }
			function initDetection() {
				$('.samCodeUnit, .samBannerUnit').each(function() {
					 if ($(this).is(':hidden')) {
						$(this).removeClass('samCodeUnit samBannerUnit');
						if ($(this).parents('.p-header').length) {
							$(this).css({'float':'right', 'max-width':'728px', 'width': '100%'})
						}
					 }
				});
				 var adUnits = $('.samCodeUnit .samItem:not(.samLazyLoading), .samBannerUnit .samItem:not(.samLazyLoading)');
				 if (XF.samAdBlockAction !== undefined && window.adBlockDetected === undefined && adUnits.length) {
					  if (XF.samAdBlockAction == 'backup' || XF.samAdBlockAction == 'message') {
						   adUnits.each(function() {
								if ($(this).height() - getIgnoredContentHeight($(this)) <= 0 && $(this).find('> a img[data-src]').length == 0) {
									 if (XF.samAdBlockAction == 'backup') {
										  var backup = $(this).find('.samBackup');
										  if (backup.length) {
											   backup.find('img').each(function() {
													$(this).attr('src', $(this).data('src'));
											   });
											   backup.fadeIn();
										  }
									 } else {
										  $('<div class="samSupportUs" />').html(XF.samSupportUsMessage).prependTo($(this));
									 }
								}
						   });
					  } else {
						   var adsBlocked = 0;
						   adUnits.each(function() {
								if ($(this).height() - getIgnoredContentHeight($(this)) == 0) {
									 adsBlocked += 1;
								};
						   });
						   if (adsBlocked) {
								if (XF.samAdBlockAction == 'notice') {
									 var content = XF.samSupportUsMessage;
									 if (XF.samAdBlockNotice.content) {
										  content = XF.samAdBlockNotice.content;
									 }
									 var notice = $('<div id="samNotice" />');
									 notice.prepend('<a role="button" id="samDismiss">×</a>');
									 notice.append('<span>' + content + '</span>');
									 if (XF.samAdBlockNotice.method == 'prepend') {
										  notice.prependTo(XF.samAdBlockNotice.element);
									 } else {
										  notice.appendTo(XF.samAdBlockNotice.element);
									 }
									 notice.fadeIn('slow');
									 XF.activate(notice);
									 $('body').addClass('samAdBlockDetected');
								} else {
									var pUrl = window.location.href;
									var rUrl = XF.samSupportRedirectUrl;
									 if (rUrl && pUrl.indexOf(rUrl) === -1) {
										  window.location.href = rUrl;
										  return;
									 }
									 var $overlay = XF.getOverlayHtml({
										  title: XF.samSupportUsTitle,
										  dismissible: false,
										  html: '<div class="blockMessage">' + XF.samSupportUsMessage + '</div>'
									 });
									 var overlay = new XF.Overlay($overlay, {
										  backdropClose: false,
										  keyboard: false,
										  escapeClose: false,
										  className: 'samSupportUsOverlay'
									 });
									 overlay.show();
									 $('head').append('<style>::-webkit-scrollbar{display: none;}</style>');
									 $('.samSupportUsOverlay').css('background-color', 'black').fadeTo('slow', 0.95);
								}
						   }
					  }
				 }
			}

			$(document).on('click', '#samDismiss', function() {
				 $(this).parent('#samNotice').fadeOut();
				 $('body').removeClass('samAdBlockDetected');
			});

			$(document).on('samInitDetection', function() {
				initDetection();
			});

			$(document).trigger('samInitDetection');
		});
	</script>
<script>
	XF.samViewCountMethod = "view";
	XF.samServerTime = 1618602623;
</script>
<script>
	$(".flags").on('touch click', function (){
		if(event.handled === false) return
		event.stopPropagation();
        event.preventDefault();
        event.handled = true;
		
		var $title = $(this).find(".data-original-title");
		if (!$title.length) {
			$(this).append('<span class="data-original-title">' + $(this).attr("data-original-title") + '</span>');
		} else {
			$title.remove();
		}
	});
</script>
<script src="/pdf/js/xf/lightbox-compiled.js?_v=fe23bc1f"></script>
<script src="/pdf/js/sv/contentratings/rate.min.js?_v=fe23bc1f"></script>
<script src="/pdf/js/siropu/am/core.min.js?_v=fe23bc1f"></script>
<script src="/pdf/js/siropu/am/ads.min.js?_v=fe23bc1f"></script>
<script>

jQuery.extend(XF.config, {
	contentrating : {
		tooltipDelay: 400,
		menuDelay: 100,
	}
});

</script>
<script>

jQuery.extend(XF.config, {
	contentrating : {
		tooltipDelay: 400,
		menuDelay: 100,
	}
});

</script>
<script>
		jQuery.extend(true, XF.config, {
			// 
			userId: 0,
			enablePush: false,
			pushAppServerKey: '',
			url: {
				fullBase: 'https://defence.pk/pdf/',
				basePath: '/pdf/',
				css: '/pdf/css.php?css=__SENTINEL__&s=14&l=1&d=1608041697',
				keepAlive: '/pdf/login/keep-alive'
			},
			cookie: {
				path: '/',
				domain: '',
				prefix: 'xf_',
				secure: true
			},
			csrf: '1618602670,6bab50f451415098cdd4b813936b5b54',
			js: {"\/pdf\/js\/xf\/lightbox-compiled.js?_v=fe23bc1f":true,"\/pdf\/js\/sv\/contentratings\/rate.min.js?_v=fe23bc1f":true,"\/pdf\/js\/siropu\/am\/core.min.js?_v=fe23bc1f":true,"\/pdf\/js\/siropu\/am\/ads.min.js?_v=fe23bc1f":true},
			css: {"public:lightbox.less":true,"public:message.less":true,"public:share_controls.less":true,"public:similar_threads.less":true,"public:siropu_ads_manager_ad.less":true,"public:snog_flags.less":true,"public:structured_list.less":true,"public:sv_contentratings.less":true,"public:thfilters_node_label.less":true,"public:xc_user_activity.less":true,"public:extra.less":true},
			time: {
				now: 1618602670,
				today: 1618599600,
				todayDow: 6,
				tomorrow: 1618686000,
				yesterday: 1618513200,
				week: 1618081200
			},
			borderSizeFeature: '3px',
			fontAwesomeWeight: 'r',
			enableRtnProtect: true,
			enableFormSubmitSticky: true,
			uploadMaxFilesize: 1342177280,
			allowedVideoExtensions: ["m4v","mov","mp4","mp4v","mpeg","mpg","ogv","webm"],
			shortcodeToEmoji: true,
			visitorCounts: {
				conversations_unread: '0',
				alerts_unread: '0',
				total_unread: '0',
				title_count: true,
				icon_indicator: true
			},
			jsState: {},
			publicMetadataLogoUrl: '',
			publicPushBadgeUrl: 'https://defence.pk/pdf/styles/default/xenforo/bell.png'
		});

		jQuery.extend(XF.phrases, {
			// 
similar_threads: "Similar threads",
			date_x_at_time_y: "{date} at {time}",
			day_x_at_time_y:  "{day} at {time}",
			yesterday_at_x:   "Yesterday at {time}",
			x_minutes_ago:    "{minutes} minutes ago",
			one_minute_ago:   "1 minute ago",
			a_moment_ago:     "A moment ago",
			today_at_x:       "Today at {time}",
			in_a_moment:      "In a moment",
			in_a_minute:      "In a minute",
			in_x_minutes:     "In {minutes} minutes",
			later_today_at_x: "Later today at {time}",
			tomorrow_at_x:    "Tomorrow at {time}",

			day0: "Sunday",
			day1: "Monday",
			day2: "Tuesday",
			day3: "Wednesday",
			day4: "Thursday",
			day5: "Friday",
			day6: "Saturday",

			dayShort0: "Sun",
			dayShort1: "Mon",
			dayShort2: "Tue",
			dayShort3: "Wed",
			dayShort4: "Thu",
			dayShort5: "Fri",
			dayShort6: "Sat",

			month0: "January",
			month1: "February",
			month2: "March",
			month3: "April",
			month4: "May",
			month5: "June",
			month6: "July",
			month7: "August",
			month8: "September",
			month9: "October",
			month10: "November",
			month11: "December",

			active_user_changed_reload_page: "The active user has changed. Reload the page for the latest version.",
			server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
			oops_we_ran_into_some_problems: "Oops! We ran into some problems.",
			oops_we_ran_into_some_problems_more_details_console: "Oops! We ran into some problems. Please try again later. More error details may be in the browser console.",
			file_too_large_to_upload: "The file is too large to be uploaded.",
			uploaded_file_is_too_large_for_server_to_process: "The uploaded file is too large for the server to process.",
			files_being_uploaded_are_you_sure: "Files are still being uploaded. Are you sure you want to submit this form?",
			attach: "Attach files",
			rich_text_box: "Rich text box",
			close: "Close",
			link_copied_to_clipboard: "Link copied to clipboard.",
			text_copied_to_clipboard: "Text copied to clipboard.",
			loading: "Loading…",

			processing: "Processing",
			'processing...': "Processing…",

			showing_x_of_y_items: "Showing {count} of {total} items",
			showing_all_items: "Showing all items",
			no_items_to_display: "No items to display",

			push_enable_notification_title: "Push notifications enabled successfully at Pakistan Defence",
			push_enable_notification_body: "Thank you for enabling push notifications!"
		});
	</script>
<form style="display:none" hidden="hidden">
<input type="text" name="_xfClientLoadTime" value="" id="_xfClientLoadTime" title="_xfClientLoadTime" tabindex="-1" />
</form>
<script type="text/template" id="xfReactTooltipTemplate">
		<div class="tooltip-content-inner">
			<div class="reactTooltip">
				
					<div class="sv-rating-type  sv-rating-type--icon-only"><div class="sv-rating-type__icon"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"
			class="sv-rating-type-icon  sv-rating-type-icon7 sv-rating-type-icon--sprite sv-rating-type-icon--sprite7  "
			alt="Positive Rating"
			title="Positive Rating"
			aria-hidden="true"></div></div>
				
					<div class="sv-rating-type  sv-rating-type--icon-only"><div class="sv-rating-type__icon"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"
			class="sv-rating-type-icon  sv-rating-type-icon8 sv-rating-type-icon--sprite sv-rating-type-icon--sprite8  "
			alt="Negative Rating"
			title="Negative Rating"
			aria-hidden="true"></div></div>
				
					<div class="sv-rating-type  sv-rating-type--icon-only"><div class="sv-rating-type__icon"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"
			class="sv-rating-type-icon  sv-rating-type-icon1 sv-rating-type-icon--sprite sv-rating-type-icon--sprite1  "
			alt="Like"
			title="Like"
			aria-hidden="true"></div></div>
				
					<div class="sv-rating-type  sv-rating-type--icon-only"><div class="sv-rating-type__icon"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"
			class="sv-rating-type-icon  sv-rating-type-icon2 sv-rating-type-icon--sprite sv-rating-type-icon--sprite2  "
			alt="Love"
			title="Love"
			aria-hidden="true"></div></div>
				
					<div class="sv-rating-type  sv-rating-type--icon-only"><div class="sv-rating-type__icon"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"
			class="sv-rating-type-icon  sv-rating-type-icon3 sv-rating-type-icon--sprite sv-rating-type-icon--sprite3  "
			alt="Haha"
			title="Haha"
			aria-hidden="true"></div></div>
				
					<div class="sv-rating-type  sv-rating-type--icon-only"><div class="sv-rating-type__icon"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"
			class="sv-rating-type-icon  sv-rating-type-icon4 sv-rating-type-icon--sprite sv-rating-type-icon--sprite4  "
			alt="Wow"
			title="Wow"
			aria-hidden="true"></div></div>
				
					<div class="sv-rating-type  sv-rating-type--icon-only"><div class="sv-rating-type__icon"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"
			class="sv-rating-type-icon  sv-rating-type-icon5 sv-rating-type-icon--sprite sv-rating-type-icon--sprite5  "
			alt="Sad"
			title="Sad"
			aria-hidden="true"></div></div>
				
					<div class="sv-rating-type  sv-rating-type--icon-only"><div class="sv-rating-type__icon"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"
			class="sv-rating-type-icon  sv-rating-type-icon6 sv-rating-type-icon--sprite sv-rating-type-icon--sprite6  "
			alt="Angry"
			title="Angry"
			aria-hidden="true"></div></div>
				
			</div>
		</div>
	</script>
<script>

$(document).ready(function(){
	var html = $('#XF');
	
	
		// Advanced search menu
		$('.focus-search-advanced').on('click', function(){ html.toggleClass('focus-search-menu-active'); });
		$('.focus-search-flex input').on('focus', function(){ html.addClass('focus-search-menu-active'); });
		$(document).on('click', function() { html.removeClass('focus-search-menu-active'); });
		$('.focus-wrap-search').on('click', function(event){ event.stopPropagation(); });
	

	
		$("[data-xenfocus-editor]").hover(function() {
			html.addClass('focus-picker--loaded');
		});
		// xenfocus editor: open and close with data-xenfocus-editor
		$("[data-xenfocus-editor]").on('click', function(event){
			html.toggleClass('focus-editor-open').addClass('focus-picker--loaded');
			event.preventDefault();
		});
		// ..and close by pressing ESC
		$(document).keyup(function(e) {
			if (e.keyCode === 27){
				html.removeClass('focus-editor-open');
			}
		});
		
		$('.focus-editor-panel').each(function(){
			// This value is used for localstorage names and class names.
			var settingName = $(this).attr('data-setting');
			var settingDefault = $(this).attr('data-setting-default');
			var settingChoice = localStorage.getItem(settingName);
			if(settingChoice === 'on'){
				$(this).attr('data-setting-status','on');
			} else if(settingChoice === 'off') {
				$(this).attr('data-setting-status','off');
			} else {
				if(settingDefault === 'on'){
					$(this).attr('data-setting-status','on');
				} else{
					$(this).attr('data-setting-status','off');
				}
			}
		});
		// Change the class and localstorage when the toggle is clicked
		$('.focus-editor-panel').on('click', function(){
			var settingName = $(this).attr('data-setting');
			var settingStatus = $(this).attr('data-setting-status');
			if(settingStatus === 'on'){
				html.removeClass(settingName);
				localStorage.setItem(settingName, 'off');
				$(this).attr('data-setting-status', 'off');
			} else {
				html.addClass(settingName);
				localStorage.setItem(settingName, 'on');
				$(this).attr('data-setting-status', 'on');
			}
		});
	
});

	

</script>
<script type="text/javascript" src="//m2d.m2.ai/pg.defence.js" async></script>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"si":10,"rayId":"640ff2644ae4596e","version":"2021.4.0"}'></script>
</body>
</html>
